ALEXD 1000 HP Engine All Trucks V1.3

This mod requires ETS2 1.31.x; 1.32.x; 1.33.x; 1.34.x; 1.35.x; 1.36.x ALEXD 1000 HP Engine All Trucks V1.3 Follow me : …

ALEXD 900 HP ENGINE ALL TRUCKS V 1.5

This mod requires ETS2 1.31; 1.32; 1.33.x; 1.34.x; 1.35.x; 1.36.x ALEXD 900 HP ENGINE ALL TRUCKS V 1.5 follow me …